Mac OS X 10.10 Yosemite Compatibility With Music Software

With the release of Apple's latest OS X 10.10 Yosemite, as always, we advise users TO NOT upgrade for at least 4 - 6 months, so that any initial bugs can be ironed out. These precautions are ultimately so that your music projects are not interrupted due to incompatibility errors.


Please see below for a list of available details on music software compatibility with OS X Yosemite (to be updated as details change):


Compatible Developers:


VSL - All products are fully compatible. Please install the latest updates available from your VSL user account.


Toontrack - All products are fully compatible. EZdrummer (1) users should download the latest EZdrummer 1.4.0 update to run with Yosemite.

Spectrasonics
- At the current time, Omnisphere, Trilian and Stylus RMX all appear to be working normally in OSX Yosemite.

Please visit your Spectrasonics User Account area to download and install the latest updates for the plugins in order to ensure compatibility.

It is also important to verify OSX 10.10 (Yosemite) compatibility with your host sequencer application before upgrading the operating system.

Full Spectrasonics details can be found below:
http://www.spectrasonics.net/support/knowledgebase_view_topic.php?id=592&categoryID=84 

iZotope
- With the latest update to iZotope Stutter Edit, all iZotope products are now fully supported under Mac OS X 10.10 Yosemite. Please see link below for further details on downloading the latest version of Stutter Edit:
http://www.timespace.com/izotope_updates/3068/stutter-edit.html 

Native Instruments (Kontakt 5)
- Native Instruments has conducted compatibility tests with Mac OS X 10.10 Yosemite which have shown current NI products to work without any specific issues under standard installations of this operating system.

However, products with a hardware dependency, such as MASCHINE, KOMPLETE KONTROL, TRAKTOR, GUITAR RIG, and Controller Editor will not launch when the AVID CoreAudioManager/Drivers are installed under 10.10 Yosemite. Native Instruments and Avid are working together to resolve this compatibility issue.

Native Instruments is currently conducting further systematic compatibility and performance tests with the release version of Yosemite, and will provide new information as it becomes available.

http://www.native-instruments.com/en/support/knowledge-base/show/3163/compatibility-of-native-instruments-products-with-mac-os-x-10.10-yosemite/

UVI (Workstation) - Latest UVI Workstation is fully compatible with OS X 10.7 and higher
 
To be confirmed:

Rob Papen

Synthogy

Garritan

Best Service (Engine)

iLok License Manager

Music Hosts / DAWs Compatibility Detail Links:

Logic Pro X - Please see forum below for user discussed details to use at your own discretion*:

https://discussions.apple.com/thread/6603002

*Please note, these are not official details from Apple.

Logic Pro 9 - Please see forum below for user discussed details to use at your own discretion*:

-- 

https://discussions.apple.com/thread/6537877

*Please note, these are not official details from Apple.

-- 

Pro Tools 10/11 - Please keep an eye on the Pro Tools Expert post for further updates: 

http://www.pro-tools-expert.com/home-page/2014/10/18/os-x-1010-yosemite-official-compatibility-statements-so-far.html

--

Live 9 - Live 9.1.5 (or higher) is compatible with OS X 10.10. You can download the latest Live version from your User Account.

See more Ableton Live details below:

https://www.ableton.com/en/articles/yosemite-compatibilty/ 

--

Live 8 - As Live 8 is a legacy version, no testing or updates have been performed with Live 8.4.2 or earlier. While it is possible that it may run, Live 8 is not officially supported on OS X 10.10. 

-- 

Cubase 7 - At time of writing, there appears to be no official mention from Steinberg on Yosemite. Please see the Steinberg community forum post for some user details*:

http://www.steinberg.net/forums/viewtopic.php?f=181&t=65411

*Please note, these are not official details from Steinberg.